Evergreen MC Resource Pack for Minecraft 1.11.2

7
29621

We’ve seen quite a lot of Minecraft resource packs over the years and a lot of these resource packs have been inspired by different things. Some resource packs are inspired by video games, some are inspired by popular TV shows, some are inspired by Mythology and, similar to these, there are tons of other packs as well. However, from time to time, certain packs surface that aren’t really inspired by anyone but still manage to look absolutely spectacular and Evergreen MC is one of these packs. It’s definitely recommended that you give this pack a shot if you’re looking for a simple and straightforward pack that doesn’t follow any peculiar art style but still looks good.

The thing we like most about Evergreen MC is the fact that its textures have a really clean look. Even though the textures of this pack carry a lot of detail, they somehow seem to be free of noise and this is definitely a big achievement because, when it comes to Minecraft resource packs, detail and noise usually go hand in hand. Other than the smooth textures, the pack seems to have a dark color palette and, while the darker colors might put a few players off, they’re ultimately a good change in this particular case because they make the textures look sleek and appealing.

The Evergreen MC resource pack has a resolution of x128 which is significantly higher than the usual x16 and this is why you’re going to need a good PC to run this resource pack without frame-rate troubles. The pack just came out a few months back but it’s already at 100% completion so you won’t need to worry about missing textures when you play it.

How to install Evergreen MC Resource Pack?

  1. Start Minecraft.
  2. Click “Options” in the start menu.
  3. Click “resource packs” in the options menu.
  4. In the resource packs menu, click “Open resource pack folder”.
  5. Put the .zip file you downloaded in the resource pack folder.

Download Link for Evergreen MC Resource Pack

for Minecraft 1.11.X

Credit: Ethanhines9911

7 COMMENTS

  1. It’s telling me it’s for an older version than 1.11.2 (which is the version I have and this says it’s for)… help!

LEAVE A REPLY

Please enter your comment!
Please enter your name here