Light Level Overlay Mod for Minecraft 1.10.2/1.9.4


The Light Level Overlay mod could be one of the best basic mods ever for Minecraft. This is because it performs a very useful task while adding no content to the game which would give the player super powers, or anything like that. Basically, this mod provides an overlay on top of torches, glowstone blocks and other light sources which shows, in plain sight, just how far the light from that source extends. The numbers which pop up around your lights will tell you how many blocks of light they actually provide, which is crucial to building environments which are safe from hostile mobs.



As anyone who has played Minecraft for a full game day already knows, bad things come out when the sun goes down. To prevent monsters from spawning in the same chunk as yourself, you need to keep enough light in an area to stop them from spawning. Because the Light Level Overlay mod is rather old when compared to other mods, it isn’t compatible with the current version of Minecraft. However, this won’t stop you from reverting to 1.6.4 to do your building, where you can be sure your home and the surrounding areas have enough light, and then converting back to the most recent version of the game.

After you’ve placed enough torches and other light sources, you’ll kind of learn just how far every light source reaches, and you won’t really need this mod anymore. The Light Level Overlay mod is an excellent tool for players who are new to the game, as well as players who are looking to use the minimum number of lights necessary to completely cover a given area and keep it free of hostile mobs. It’s a simple mod designed to work with Forge which would work fine with all your other Forge mods if it wasn’t so dated. It still works though, so it’s not without use yet.

Light Level Overlay Mod for Minecraft 1.9 Changelogs

  • Update in-game config support
  • Update code due to breaking API changes in forge 1.9-

Download Links for Light Level Overlay Mod

Note: To run this mod you must have Forge API!

for Minecraft 1.10 / 1.10.2 / 1.9.4 / 1.9

for Minecraft 1.8.9

for Minecraft 1.7.10

Credit: oldjunyi