Horse Accessories Mod for Minecraft 1.6.4

3845

The HorseAccessories mod lets players craft a number of useful items for beefing up their steeds and helping horses to live longer, more productive lives. Unlike many older mods which find their features slowly trickling into the basic Minecraft code and end up going obsolete, this mod from 1.6.4 is still useful today because there is no way to craft items like saddles in Minecraft. While it’s possible to make horse armor, that’s just one of the accessories needed to get a good war horse up and galloping. Plus, this mod adds some other accessories which don’t normally appear in Minecraft, which is cool.

horse-accessories-mod

For one, the Horse Accessories mod lets you craft name tags, which you can then use to name your friendly horses, or any other animals you might have around and want to keep around. The mod also makes it so horses spawn in a number of additional biomes, including biomes where horses would never normally be seen, like deserts, dense forests and even extreme hills biomes, though the attached config file has the last biome disabled by default. The diamonds required to craft many of these modded recipes make it so players can’t get overpowered right when starting a new world.

horse-accessories-minecraft

horse-accessories-3

Besides seeing horses in a number of new locations, you can expect to see horses in greater concentrations as well. While you might normally run into one or two adults and a similar number of foals while roaming around, the Horse Accessories mod makes it so you can find dozens at a time grazing together. You’ll be finding so many horses that you might actually consider killing the extras you find, to get another reliable source of leather in case you don’t have enough cows nearby. Overall this mod improves horses significantly and makes them more usable, which is great.

Horse Accessories Mod for Minecraft 1.6.4 Changelogs

  • MorphCore Optimizations and Bug Fixes

Download Links for Horse Accessories Mod

for Minecraft 1.6.4 – Requires Forge API and MorphCore

Credit: MorpheusZero – Original Thread on Minecraft Forum

LEAVE A REPLY