Improved First Person Mod for Minecraft 1.6.4


Most players will be able to tell what the Improved First Person mod does just from seeing the name, and that’s a sure sign you’ve got a mod which is easy to understand. Minecraft is already played in the first person perspective by default, but it leaves a lot to be desired – especially things like arms behind the detached hands floating in front of your eyes, just to name one great example. This mod seeks to improve the player’s interface with the world surrounding them by allowing the player to look down and see arms and a chest.




It might seem like a small thing for a mod to do and admittedly, the Improved First Person mod is pretty small. It’s also one of the only mods for Minecraft today which performs this function, a fact which makes it unique even if it is limited by its coding to running only on older versions of Minecraft. Designed for 1.6.4, you won’t be able to use this mod on newer Minecraft clients, but that’s not stopping you at all from turning back your game version in your player profile and giving it a whirl. You’ll notice a sort of rounding of your vision as well to give you the peripheral Minecraft never included.



This alone makes the Improved First Person mod worth trying since it can help to prevent creepers from sneaking up on you. When you can see things out of the corners of your eyes like normal instead of having some strange tunnel vision forced on your perspective, it allows you to dodge quite a few hazards, not just exploding creepers. It can take a little getting used to at first because of the added vision and the more realistic movement and running, but this mod does a lot of good for Minecraft.

How to install Improved First Person Mod?

  1. Install Forge RenderPlayer API
  2. Copy the .jar for Improved First Person to the mods folder.
  3. Have fun!

Download Links for Improved First Person Mod

for Minecraft 1.6.4

Credit: Zaggy1024 – Original Thread on CursForge


  1. Please make a version of this mod for 1.9.4!!! I want to install this mod and use it in my friend’s realm server because it looks cool, but I can’t do that unless I use the latest version of minecraft. 🙁